DIY Audio Projects Forum
 NEW  Matt presents bias and operation data for the 6V6 tube in SE operation - 6V6 Single-Ended (SE) Ultra Linear (UL) Bias Optimization.

DIY Audio Projects Forum

Welcome to the DIY Audio Projects Message Forum. Use these forums to discuss Hi-Fi audio and to share your DIY Audio Projects. Registration is free and required to post messages and view the file attachments. Registration will only take a minute and registered users do not see any advertisements. After you have completed the online registration process, check your email (including spam/junk folder) for the verification email to activate your account. New members are under moderation - so your posts will not be visible until approved by a moderator. See the Read Me 1st, Forum RULES and Forum FAQ to get started on the forum.

It is currently 10 May 2021, 22:26

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: 3-way crossover
PostPosted: 27 Mar 2021, 06:52 
Offline

Joined: 22 Mar 2021, 11:42
Posts: 2
I have put together a 3-way crossover circuit: sub (300W max), mid low (200W max) and mid hi (120W max), to which I will then add a horn piezo tweeter to kick in at 2KHz. The circuit is in the image below.

I've tried the mid hi speaker only (right now the other two are not available), and what I have experienced is the following: as I raise the volume, the speaker starts clicking, especially when a low thumping frequency is hit.

But if I add a 2 or 4 Ohm 100W wirewound resistor at the very beginning of the circuit, before the signal goes to the different drivers, the quality of the sound is much better. The mid high speaker works really well and delivers pretty sharply. The resistor also gets really hot after a minute.

I have shorted the other drivers as well as left them open: same result.

Any ideas why? I have been told it's not a good idea to use a 4R at the beginning of the circuit because it uses up a lot of voltage, but now I see it could be actually very useful.


This post has a file attachment. Please login or register to access it. Only Registered Members may view attached files.



Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
DIY Tube Projects :: DIY Tube Amp Kits :: DIY Speaker Projects :: DIY Solid State Projects :: DIY IC / Op-amp Projects :: DIY Phono Projects :: DIY Cable Projects :: Hi-Fi Audio Schematics
© diyAudioProjects.com - Terms of Service - Privacy Policy