DIY Audio Projects Forum
 NEW  Matt presents bias and operation data for the 6V6 tube in SE operation - 6V6 Single-Ended (SE) Ultra Linear (UL) Bias Optimization.

DIY Audio Projects Forum

Welcome to the DIY Audio Projects Message Forum. Use these forums to discuss Hi-Fi audio and to share your DIY Audio Projects. Registration is free and required to post messages and view the file attachments. Registration will only take a minute and registered users do not see any advertisements. After you have completed the online registration process, check your email (including spam/junk folder) for the verification email to activate your account. New members are under moderation - so your posts will not be visible until approved by a moderator. See the Read Me 1st, Forum RULES and Forum FAQ to get started on the forum.

It is currently 11 Dec 2018, 18:39

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: New bad transformers
PostPosted: 06 Oct 2018, 15:16 
Offline

Joined: 30 Aug 2017, 09:49
Posts: 37
I want to say right off. I do not want to put any company down but. I received 2 power transformers from AES. They were hammond. The first one ran very hot! I was drawing only half the current the transformer was rated at. It was in a 40 meter am transmitter. The HV winding burnt up and smoked father only one week. With very little use. I only had a few QSO 's on it. I called AES and a new one was sent. I instilled it then less then a few seconds the 6v winding opened up!. I called AES just 10 minutes after receiving it. I was told that they would call Hammond about the 2 van new transformers. Well father almost 2 week and many phone calls and emails. I still have a bad transformer and no return calls or refund or new transformer. I have used AES and Hammond transformers for years and never had problem till now. Had this ever happened to any one else. I think I just shop at a different vendor and use another transformer brand! 73's

_________________
Alpha Wolf


Top
 Profile  
 
 Post subject: Re: New bad transformers
PostPosted: 08 Oct 2018, 17:39 
Offline

Joined: 09 Oct 2012, 19:43
Posts: 318
Location: Vancouver Canada
If you called Hammond in Canada it is our Thanksgiving so you will not hear from them until they are back in the office probably Wed. I to have used Hammond for 40+ yrs with little problem. But there is always an exception but they have always been good on the phone.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: eshazen and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
DIY Tube Projects :: DIY Tube Amp Kits :: DIY Speaker Projects :: DIY Solid State Projects :: DIY IC / Op-amp Projects :: DIY Phono Projects :: DIY Cable Projects :: Hi-Fi Audio Schematics
© diyAudioProjects.com - Terms of Service - Privacy Policy