DIY Audio Projects Forum
 NEW  Matt presents bias and operation data for the 6V6 tube in SE operation - 6V6 Single-Ended (SE) Ultra Linear (UL) Bias Optimization.

DIY Audio Projects Forum

Welcome to the DIY Audio Projects Message Forum. Use these forums to discuss Hi-Fi audio and to share your DIY Audio Projects. Registration is free and required to post messages and view the file attachments. Registration will only take a minute and registered users do not see any advertisements. After you have completed the online registration process, check your email (including spam/junk folder) for the verification email to activate your account. New members are under moderation - so your posts will not be visible until approved by a moderator. See the Read Me 1st, Forum RULES and Forum FAQ to get started on the forum.

It is currently 21 Sep 2017, 21:35

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: 25 Jun 2017, 11:09 
Offline

Joined: 25 Jun 2017, 10:53
Posts: 3
My Marantz PM 68 which has been working fine just stopped working. The power light was still on but the sound just stopped.
Unplugged it, hooked up my backup amp. Tried the Marantz again the next day. Worked fine for about half an hour then stopped working. Volume was at less than 25%. Tried all the inputs. Nothing. Backup amp worked fine. Thanks for any help. Hope this is the proper forum to post this.


Top
 Profile  
 
PostPosted: 27 Jun 2017, 05:58 
Offline
User avatar

Joined: 05 Aug 2016, 14:35
Posts: 213
DIYrp wrote:
My Marantz PM 68 which has been working fine just stopped working. The power light was still on but the sound just stopped.
Unplugged it, hooked up my backup amp. Tried the Marantz again the next day. Worked fine for about half an hour then stopped working. Volume was at less than 25%. Tried all the inputs. Nothing. Backup amp worked fine. Thanks for any help. Hope this is the proper forum to post this.


This is not something you will fix yourself without considerable experience and tooling. Just count yourself lucky that it uses discreet output devices and drivers. But, I would start with examining the filter caps (and any other electrolytic caps) for signs of damage or swelling. Next would be internal fuses. Then the delay relays, which can go weak. That the problem as-reported is affecting both channels suggests that it is in the power-supply somewhere - hopeful.

Best of luck with it!


Top
 Profile  
 
PostPosted: 27 Jun 2017, 13:02 
Offline

Joined: 25 Jun 2017, 10:53
Posts: 3
Thanks for your help. Much appreciated.


Top
 Profile  
 
PostPosted: 27 Jun 2017, 16:00 
Offline
Project Author
User avatar

Joined: 04 Jun 2008, 20:59
Posts: 3415
Location: Arizona, USA
Hi, Power supply possibly, but a number of Marantz (and other brands) have a speaker muting relay and the contacts get cruddy causing similar issues. I have to clean my 2265B about every 5 years or so. The 2250 needed it a while back as well.

If not the relay this could be something a DIYER might not be able to fix unless you have considerable experience. The questions lead me to believe otherwise. Good luck

Good listening
Bruce

_________________
Some of my DIY Tube Amplifier Projects:


Top
 Profile  
 
PostPosted: 28 Jun 2017, 09:26 
Offline

Joined: 25 Jun 2017, 10:53
Posts: 3
Thanks Bruce, You are right I don't have much expertise. I may have to take it in again (3rd time) or start shopping)


Top
 Profile  
 
PostPosted: 28 Jun 2017, 10:08 
Offline
User avatar

Joined: 05 Aug 2016, 14:35
Posts: 213
DIYrp wrote:
Thanks Bruce, You are right I don't have much expertise. I may have to take it in again (3rd time) or start shopping)



OK - here we go!

If the alternative is landfill, then this may be a teachable moment for you. If, with some care, you can go through some basic troubleshooting and find the problem - think of the pleasure you will take from it.

Do you have the capacity to take some pictures of the insides, with specific reference to the power-supply?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
DIY Tube Projects :: DIY Tube Amp Kits :: DIY Speaker Projects :: DIY Solid State Projects :: DIY IC / Op-amp Projects :: DIY Phono Projects :: DIY Cable Projects :: Hi-Fi Audio Schematics
© diyAudioProjects.com - Terms of Service - Privacy Policy